Перейти к содержимому


Фотография
* * * * - 7 Голосов

Wrye Bash и Skyrim

bashed patch башед патч как создать скайрим

  • Авторизуйтесь для ответа в теме

#241 Ссылка на это сообщение Siegrun

Siegrun
  • Бяка Зюка

  • 17 800 сообщений
  •    
Наш автор

Отправлено

Тема для вопросов и ответов. Кто использует сам - помогите другим.

Кроме верной установки Питона (для Облы) и верного выбора версии для вашей системы:

МОДЫ и архивы, устанавливаемые с wrye bash, должны иметь написание названия и пути НА ЛАТИНИЦЕ.
ВАШ аккаунт на компе (имя пользователя) должен иметь написание и пути НА ЛАТИНИЦЕ.


Да я тоже тебя люблю (пока его тут нет). © Монгол
Я трудный человек, но если вы рядом со мной, то и вы не простые люди.
LoveFlower002.png



  • Авторизуйтесь для ответа в теме
Сообщений в теме: 755

#242 Ссылка на это сообщение Lord-Vadim

Lord-Vadim
  • Следопыт
  • 77 сообщений
  •    

Отправлено

Подскажите пожалуйста, есть где нибудь описание скриптового языка используемого в файле wizard.txt ?

Конкретная проблема: при установке мода мне необходимо, что бы часть архива была записана не в папку 'Data', а в корневую папку 'Skyrim', как это сделать?

Зараннее спасибо!!!


Сообщение отредактировал Lord-Vadim: 18 Июль 2013 - 19:15


#243 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

Подскажите пожалуйста, есть где нибудь описание скриптового языка используемого в файле wizard.txt ?

В папке Mopy есть папка Docs, в ней файл Wrye Bash Technical Readme.html с нужным вам описанием. Точно не уверен, но по-моему, записать в корневую папку из wizard'а не удастся...



#244 Ссылка на это сообщение Lord-Vadim

Lord-Vadim
  • Следопыт
  • 77 сообщений
  •    

Отправлено

При использовании в wizard.txt функции:

 

_Ver = CompareGameVersion("1.8.151.0.7")

 

Выдает ошибку:

 

Traceback (most recent call last):
File "bash\basher.py", line 10142, in Execute
panel = iniList.GetParent().GetParent().GetParent()
AttributeError: 'NoneType' object has no attribute 'GetParent'

 

Не подскажите, в чем может быть проблема?

Или подскажите другой способ определения версии установленного Skyrim?

 

(Wrye Bash 304 Standalone, Windows 7 x64, Имя пользователя/компьютера - латиница)

 

Зараннее спасибо!!!


Сообщение отредактировал Lord-Vadim: 20 Июль 2013 - 14:55


#245 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

При использовании в wizard.txt функции:

 

_Ver = CompareGameVersion("1.8.151.0.7")

 

 

Не подскажите, в чем может быть проблема?

 

В версии... Используемый вами Wrye Bash поддерживает Скайрим начиная с версии 1.9.32.0.8



#246 Ссылка на это сообщение Lord-Vadim

Lord-Vadim
  • Следопыт
  • 77 сообщений
  •    

Отправлено

Установлен Skyrim версии 1.9.32.0.8

 

_Ver = CompareGameVersion("1.9.32.0.8")

 

Тоже выдает ошибку.



#247 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

Установлен Skyrim версии 1.9.32.0.8

 

_Ver = CompareGameVersion("1.9.32.0.8")

 

Тоже выдает ошибку.

Надо писать вот так:

If CompareGameVersion("1.9.32.0.8") < 0   ; -1 -версия ниже, 0 - версия совпала, 1 - версия больше 
Return
EndIf


#248 Ссылка на это сообщение Lord-Vadim

Lord-Vadim
  • Следопыт
  • 77 сообщений
  •    

Отправлено

И так пробовал. Выдает ту же ошибку.


Сообщение отредактировал Lord-Vadim: 20 Июль 2013 - 18:37


#249 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

И так пробовал. Выдает ту же ошибку.

Попробуй использовать вот эту функцию

 

 


RequireVersions game_version [, se_version, ge_version, wrye_bash_version]

  • game_version - Version of the game to test for. See CompareGameVersion for the proper format of the string.
  • se_version - Optional. Version of the Script Extender to test for. See CompareSEVersion for the proper format of the string.
  • ge_version - Optional. Version of the Graphics Extender to test for. See CompareGEVersion for the proper format of the string.
  • wrye_bash_version - Optional. Version of Wrye Bash to test for. See CompareWBVersion for more info.

Вот реальный пример из мода Hanterborn

 

RequireVersions "1.9.32.0", "", "", "303" ; Skyrim version, SKSE, (SKGE doesn't exist yet), Wrye Bash 



#250 Ссылка на это сообщение Lord-Vadim

Lord-Vadim
  • Следопыт
  • 77 сообщений
  •    

Отправлено

Все. Разобрался.

В параметр надо передавать только четыре цифры версии: CompareGameVersion("1.9.32.0"), тогда все работает.

Спасибо за помощь!



#251 Ссылка на это сообщение RandTor

RandTor
  • Новенький
  • 4 сообщений

Отправлено

народ как поменять путь к папке чтобы Ври Баш работал у меня путь такой C:\Users\Роман\Documents\My Games\Skyrim я не как не могу понять как сменить Роман на Roman?? может кто подскажет как заменить ??



#252 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

народ как поменять путь к папке чтобы Ври Баш работал у меня путь такой C:\Users\Роман\Documents\My Games\Skyrim я не как не могу понять как сменить Роман на Roman?? может кто подскажет как заменить ??

для Виндовс ХР

для Виндовс 7

а проще всего, завести нового пользователя и под ним установить врай баш!



#253 Ссылка на это сообщение RandTor

RandTor
  • Новенький
  • 4 сообщений

Отправлено

Это как добавить нового пользователя с правами администратора?



#254 Ссылка на это сообщение YourBunnyWrote

YourBunnyWrote
  • Рабочий лень
  • 3 201 сообщений
  •    
Наш автор

Отправлено

Пуск -> Панель управления -> Учетные записи пользователей и семейная безопасность ->Учетные записи пользователей ->Управление учетными записями


TESAll.Ru в Discord бесплатно, без SMS.


#255 Ссылка на это сообщение Drelamath

Drelamath
  • Талант
  • 284 сообщений

Отправлено

Скидываю моды в Bash Installers , запускаю программу, нажимаю вкладку "установщики" , загрузка, и нифига. Пустое окно. Зато открывается новое с непонятным текстом.

Текст.


Drelamath - 100%


#256 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

IOError: [Errno 2] No such file or directory: u'M:\\Steam\\steamapps\\common\\Skyrim Mods\\Bash Installers\\Новые алхимические ингредиенты.7z_unicode_safe.tmp'
 

Просто переименуйте архив "Новые алхимические ингредиенты.7z" в какой-нибудь "New ingredients.7z"...



#257 Ссылка на это сообщение Drelamath

Drelamath
  • Талант
  • 284 сообщений

Отправлено

Просто переименуйте архив "Новые алхимические ингредиенты.7z" в какой-нибудь "New ingredients.7z"...

Эх, дело в том что не видно всех архивов, даже с английским названием. Переименовал, не помогло. Переустанавливал, не помогло.
Попробовал переустановить во 2 раз, и все появилось. Бывает же.


Сообщение отредактировал Drelamath: 29 Июль 2013 - 12:17

Drelamath - 100%


#258 Ссылка на это сообщение Vaihan

Vaihan
  • Новенький
  • 2 сообщений

Отправлено

Пуск -> Панель управления -> Учетные записи пользователей и семейная безопасность ->Учетные записи пользователей ->Управление учетными записями

Благодарю за подсказку) 



#259 Ссылка на это сообщение Evanxxxx

Evanxxxx
  • Новенький
  • 7 сообщений

Отправлено

Такая вот ошибка:

Traceback (most recent call last):
  File "Wrye Bash Launcher.pyw", line 90, in <module>
    from bash import bash
  File "zipextimporter.pyo", line 92, in load_module
  File "bash\bash.pyo", line 41, in <module>
    
  File "zipextimporter.pyo", line 92, in load_module
  File "bash\bolt.pyo", line 294, in <module>
    
  File "locale.pyo", line 539, in setlocale
locale.Error: unsupported locale setting
 

можете помочь?



#260 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

locale.Error: unsupported locale setting

Ошибка - не поддерживаемые локальные настройки...

 

Какие страна и язык у вас установлены в системе, на каком языке имя пользователя компьютера, и архивы модов на каком языке пытаетесь установить?



#261 Ссылка на это сообщение Kirguh

Kirguh
  • Новенький
  • 11 сообщений

Отправлено

Как поставить этот мод:

http://tesall.ru/fil...grovyh-modelej/

с помощью Браша?


Пх’нглуи мглв’нафх Ктулху Р’льех вгах’нагл фхтагн





Темы с аналогичным тегами bashed patch, башед патч, как создать, скайрим

Количество пользователей, читающих эту тему: 1

0 пользователей, 0 гостей, 0 скрытых


    Google Mobile (1)