Перейти к содержимому

Купить Dark Souls 3 в Gameray всего за 1699 рублей

Фотография
- - - - -

Wrye Bash


  • Авторизуйтесь для ответа в теме

#641 Ссылка на это сообщение venivedivici

venivedivici
  • Новенький
  • 29 сообщений

Отправлено

Подскажите, пожалуйста, если я хочу обновить Wrye Bash ( с версии 205 до версии 208, вдруг важно), то мне нужно тупо скопировать папки Дата и Мопи в папку с обливионом поверх старого Wrye Bash с заменой файлов? Или для начала старый Wrye Bash нужно снести?

По темам и разделам прошелся, вроде ответа на этот вопрос не нашел.


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 744

#642 Ссылка на это сообщение Сережкиус

Сережкиус
  • Скиталец
  • 56 сообщений
  •    

Отправлено

Разобрался таки в чем косяк  :) файл с настройками (Oblivion.ini) у друга брал, а там у него над многими параметрами стояли комментарии на русском. Например:

 

;Отключение этой функции уберет границы карты

 

Ох и много же текста пришлось убирать  :dash2: зато теперь без проблем все запускается  :good2:


Сообщение отредактировал Сережкиус: 26 Январь 2013 - 20:21

В миру он был известен, как Сонджу...


#643 Ссылка на это сообщение Пакость

Пакость
  • Большая гадина
  • 733 сообщений
  •    
Наш автор

Отправлено

Сережкиус, а вариант работающий Oblivion.ini с комментами в студию? Вообще считал что такое как-бы невозможно.



#644 Ссылка на это сообщение Сережкиус

Сережкиус
  • Скиталец
  • 56 сообщений
  •    

Отправлено

Попробовал альтернативный способ, при котором все работает и с комментариями. Просто перекодировал Oblivion.ini из Utf-8 в Win кодировку. Игра и Wrye Bash запускаются и работают на ура  :) прилагаю архив с данным файлом (перекодированным).

 

http://moemesto.ru/s...ith_comments.7z

 

P.S. Игра может ругаться на разрешение экрана, которое указано в файле. У меня экран нестандартный 1366 на 768. Если не запустится, поменяйте вручную эти 2 значения.


Сообщение отредактировал Сережкиус: 27 Январь 2013 - 08:02

В миру он был известен, как Сонджу...


#645 Ссылка на это сообщение Djuni

Djuni
  • Новенький
  • 19 сообщений

Отправлено

6bc78cbdc06d.jpg

 

 

Ребят почему мой Варбаш не хочет запускать босс ( Да и плагинов в Bash Installers не видит... 

Выдаёт Еррор. 



#646 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено


 

Выдаёт Еррор. 

Боюсь, ему не нравится твоя папка "Игры" на кириллице...



#647 Ссылка на это сообщение Djuni

Djuni
  • Новенький
  • 19 сообщений

Отправлено

Боюсь, ему не нравится твоя папка "Игры" на кириллице...

Ого,  ты оказался прав :) Спасибо. 



#648 Ссылка на это сообщение Jack~Black

Jack~Black
  • Новенький
  • 8 сообщений

Отправлено

Доброго времени суток :3 

Прочитала всё, что написано на форуме, но конкретно своей проблемы так и не нашла, так кажется, что я тут единственная установила Wrye Bash (standalone) 303-ей версии (предоставленной на этом сайте).

 

Всё шло хорошо до тех пор, пока я не открыла вкладку "Установщики", где сперва произвелось обновление установщиков, а после отобразился пакет ==Last== (то есть, всё стабильно). 

 

Но когда я собираюсь загрузить новый мод (Архив, папка - не важно), то идёт загрузка, вдруг она прерывается, и выскакивает вот такое окошко: 

 

 

wxPython: stoudt/stderr

 

 

Traceback (most recent call last):
  File "bash\basher.pyo", line 6189, in RefreshData
  File "bash\basher.pyo", line 3810, in OnShow
  File "bash\bosh.pyo", line 9038, in refresh
  File "bash\bosh.pyo", line 9262, in refreshInstallers
  File "bash\bosh.pyo", line 7856, in refreshBasic
  File "bash\bosh.pyo", line 8480, in refreshSource
  File "bash\bosh.pyo", line 158, in listArchiveContents
  File "subprocess.pyo", line 679, in __init__
  File "subprocess.pyo", line 896, in _execute_child
UnicodeEncodeError: 'ascii' codec can't encode characters in position 4-10: ordinal not in range(128)
 
 
Я не имею ни малейшего представления о том, что это значит (за что прошу прощения, потому как раньше с такой программой никогда не работала), меня напрягает первая строчка "wxPython", ведь он не установлен у меня :с 
 
 
Я предполагаю, что дело в версии, потому что, на мой взгляд, она довольно сырая, и мне стоит скачать какую-то другую, но установив одну более раннюю версию, чем 303-я, у меня не запустился даже лаунчер, выдав очередную ошибку. 
 
И я читала FCOM, но там всё как-то просто, никаких описаний об ошибках не было вообще ><" 
 
Но, может, дело не в версии? с этим вопросом я и обращаюсь к Вам. Я очень надеюсь на ваши помощь и совет, спасибо заранее (и прошу прощения, наверное, уже надоели подобные глупые вопросы и просьбы о помощи).
 
P.s. (как же без него) Добью вас ещё одним глупым вопросом: скажите, а чем вообще отличаются версии standalone и с библиотекой Python? о.о и какую устанавливать желательно? 
 
Жду ответа, как соловей - лета ~ 
Добра Вам.


#649 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

Строчка про "wxPython" не должна вас пугать - программа написана на этом языке и сообщения об ошибках начинаются указанием на это.

А вот строчка "line 158, in listArchiveContents" явно указывает на причину ошибки - что-то ей не нравится в содержании архива. Значит бороться надо с этим архивом, попробуйте его переименовать, если название содержит кириллицу или японицу или иные запрещенные символы... 

 

Версии различаются способом запуска - питон-версия запускается лаунчером, а одиночная версия exe файлом. И требованием к наличию библиотек для работы - питон-версия - установленный питон, одиночная - библиотека C++. С одиночной версией проблем меньше...



#650 Ссылка на это сообщение Jack~Black

Jack~Black
  • Новенький
  • 8 сообщений

Отправлено

Дело в том, что архив полностью на английском, никаких посторонних символов в нём нет (и я пробовала закидывать любые другие архивы, но ошибка осталась прежней) 



#651 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

Дело в том, что архив полностью на английском, никаких посторонних символов в нём нет (и я пробовала закидывать любые другие архивы, но ошибка осталась прежней) 

Дайте ссылку на мод, чтобы можно было проверить.



#652 Ссылка на это сообщение Daevy

Daevy
  • Новенький
  • 2 сообщений

Отправлено

Проблема с Wrye Bash 

Не видит архив, выдал один раз ошибку и запомнил блин архив, удалил и установил заново, а он блин помнит и игнорирует архив, 

Выдаёт постоянно ошибки : 

 

Traceback (most recent call last):
  File "bash\basher.py", line 5139, in OnShowPage
    self.GetPage(event.GetSelection()).OnShow()
  File "bash\basher.py", line 3810, in OnShow
    if data.refresh(progress,what,self.fullRefresh):
  File "bash\bosh.py", line 9038, in refresh
    if 'I' in what: changed |= self.refreshInstallers(progress,fullRefresh)
  File "bash\bosh.py", line 9262, in refreshInstallers
    try: installer.refreshBasic(apath,SubProgress(progress,index,index+1))
  File "bash\bosh.py", line 7856, in refreshBasic
    self.refreshSource(archive,progress,fullRefresh)
  File "bash\bosh.py", line 8480, in refreshSource
    ins = listArchiveContents(tempArch.s)
  File "bash\bosh.py", line 158, in listArchiveContents
    ins, err = Popen(command, stdout=PIPE, startupinfo=startupinfo).communicate()
  File "C:\Python27\lib\subprocess.py", line 679, in __init__
    errread, errwrite)
  File "C:\Python27\lib\subprocess.py", line 896, in _execute_child
    startupinfo)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 4-8: ordinal not in range(128)
 
Использую версию Питон, просто разрыв жопы, хотя бы БОСС смог вылечить.
Как вылечить проблему с отображением архива ?


#653 Ссылка на это сообщение Jack~Black

Jack~Black
  • Новенький
  • 8 сообщений

Отправлено

Пожалуйста: http://chakaru-11.li...l.com/2775.html



#654 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

Пожалуйста: http://chakaru-11.li...l.com/2775.html

Так не пойдет! Для получения файла требуется регистрация... 



Проблема с Wrye Bash 

Не видит архив, выдал один раз ошибку и запомнил блин архив, удалил и установил заново, а он блин помнит и игнорирует архив, 

Выдаёт постоянно ошибки : 

 

 
UnicodeEncodeError: 'ascii' codec can't encode characters in position 4-8: ordinal not in range(128)
 
Как вылечить проблему с отображением архива ?

Переименовывать архив пробовали?



#655 Ссылка на это сообщение Daevy

Daevy
  • Новенький
  • 2 сообщений

Отправлено

Так не пойдет! Для получения файла требуется регистрация... 



Переименовывать архив пробовали?

Добавлял к имени архива FLOP, все равно игнорирует.



#656 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

Добавлял к имени архива FLOP, все равно игнорирует.

Надо не добавлять, а полностью менять название, на короткое и простое, например - "test". Если ошибка остается, нужно смотреть внутрь архива..

 

До этого Wrye Bash работал?.



#657 Ссылка на это сообщение Jack~Black

Jack~Black
  • Новенький
  • 8 сообщений

Отправлено

Пардон

Ну тогда прямо с сайта: http://tesall.ru/fil...sta-online-mod/



#658 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

Пардон

Ну тогда прямо с сайта: http://tesall.ru/fil...sta-online-mod/

Я поместил его в папку Bash Installers, открыл Wrye Bash (303-й) и перешел на вкладку Установщики - архив нормально отобразился, и даже мод нормально установился!

 

А у вас именно этот архив, с нашего сайта выдает ошибку, или такой же, но с другого?..



#659 Ссылка на это сообщение Jack~Black

Jack~Black
  • Новенький
  • 8 сообщений

Отправлено

Абсолютно любой архив выдаёт такую ошибку :с 

И даже пробовала скачивать с разных сайтов: с вашего и с оригинального, но без изменений

Переустановка также не помогла 



#660 Ссылка на это сообщение Umbakano Jr

Umbakano Jr
  • Крестный внук

  • 3 967 сообщений
  •    
Наш автор

Отправлено

У вас что-то с установкой Wrye Bash.
Надо начинать с начала... Какая у вас Виндовс?

#661 Ссылка на это сообщение Jack~Black

Jack~Black
  • Новенький
  • 8 сообщений

Отправлено

У вас что-то с установкой Wrye Bash.
Надо начинать с начала... Какая у вас Виндовс?

Очень надеюсь

Windows7 x64 :3






Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 скрытых