Плагин для OBSE который, как понятно из названия, расширяет возможности стандартного редактора TES IV: Construction Set. Скажите, кто из вас не мечтал, чтобы это ужасное окно редактора скриптов само проставляло табуляцию? Кому из вас не мешали в работе постоянные окошки с предупреждениями от конструктора? А не приходилось ли вам сталкиваться с тем, чтобы конструктор закрывался от одного вашего небрежного действия и ваша полуторачасовая работа летела коту под хвост? Так или иначе вы не сможете не оценить вклад автора этого замечательного плагина: shadeMe, за что ему большой поклон.
Construction Set Extender посвящена статья на нашем сайте, из которой вы сможете больше узнать обо всех новых функциях этого замечательного плагина и о том, как ими пользоватся. Появились вопросы? Добро пожаловать в обсуждение на нашем форуме.

Установка Construction Set Extender

Скачайте архив construction-set-extender.7z. Откройте контекстное меню щелчком правой клавиши мыши на скачанном архиве, выберите пункт "Свойства". Нажмите кнопку "Разблокировать", затем нажмите кнопку "ОК". Распакуйте файлы из папки "Файлы из этой папки скопировать в папку с игрой" из архива в папку с установленной игрой. Запускайте редактор при помощи загрузчика OBSE.
Если в процессе загрузки редактора вы видите ошибку, которая сообщает вам, что CSE не смог загрузиться, вам необходимо закрыть редактор и запустить загрузчик OBSE с привилегиями администратора системы. Зайдите в свойства ярлыка, перейдите на вкладку "Совместимость" и поставьте галочку напротив параметра "Выполнять эту программу от имени администратора".
Обратите внимание! Новая версия CSE требует бета версию OBSE 21 или выше. Скачать её вы можете у нас на сайте перейдя по ссылке, указанной в требованиях ниже.

Требования: Oblivion Золотое издание, Construction Set, OBSE v.21 beta 4 или выше, .NET Framework 4.0+, Распространяемый пакет Visual C++ для Visual Studio 2015, DirectX 9.0c Runtime
Загрузил:
YourBunnyWrote
36

Комментарии

Добавить комментарий

Уже 6.1 вышел.

Наконец-то дождался!!!!!!!!

Это очень стабильный релиз с множеством правок. НО.

Есть один недостаток, если вы используете проги- инжекторы такие как ENB, SweetFX или FXAA Injector, то редактор скорее всего зависнет или самоубьется))

Если у Вас такая проблема- удалите на время использования редактора файл d3d9.dll из папки игры.

Надеюсь информация была полезной)

Запускайте редактор при помощи загрузчика OBSE.

Напомните как, пожалуйста.

Надо что-то дописять в ярлык загрузчика OBSE, а вот что не помню...

YourBunnyWrote
администратор
автор
12.04.2014 — 12:54

путь_до_папки_с_обливионом\obse_loader.exe -editor

Напомните как, пожалуйста.

Надо что-то дописять в ярлык загрузчика OBSE, а вот что не помню...

-editor

Установил. Игра и CS вылетают даже после удаления extender'a. Что делать?

Спасибо за новую версию. Как же я пропустила обновку, мучилась со старой версией и обсе 21...

YourBunnyWrote
администратор
автор
26.04.2015 — 18:05

На нексусе уже есть 6.3. Нет пока времени здесь обновить.

На нексусе уже есть 6.3. Нет пока времени здесь обновить.

Подписалась на обновку, теперь точно не пропущу.

Тем временем буду пилить Нерим...

Народ такой вопрос, почему при включении редактора скриптов программа выдаёт ошибку и закрывается?
и почему папки в \Data\BGSEE\Script Editor все пустые? это так и должно быть? уже качал и нексуса и этого сайта.

YourBunnyWrote
администратор
автор
05.05.2015 — 21:36

Народ такой вопрос, почему при включении редактора скриптов программа выдаёт ошибку и закрывается?

Нужно разблокировать архив перед распаковкой. Открой свойства скачанного архива, нажми кнопку "Разблокировать" и потом распаковывай.

Нужно разблокировать архив перед распаковкой. Открой свойства скачанного архива, нажми кнопку "Разблокировать" и потом распаковывай.

Огромное спасибо! = ) теперь заработало!

Ура, спасибо за обновку!

А тем временем, CSE до 7,0 обновился.

А тем временем, CSE до 7,0 обновился.

Отличная вещь! а то после нескольких часов работы со стандартным редактором скриптов у меня происходило помутнение разума

Его хоть перевели на русский???

YourBunnyWrote
администратор
автор
24.06.2015 — 16:02

Нет конечно.

Новая версия CSE требует бета версию OBSE 21 или выше.

А у кого-то стимовская версия игры, и для неё доступна только OBSE 17 :c

Редактор скриптов работает, но при попытке прокрутить рабочую зону происходит ошибка и все закрывается.

Всем привет! dll Fix тоже не помог. То есть весь редактор работает без проблем, но в редакторе скриптов при нормальном режиме где подсвечиваются элементы нельзя прокручивать текстовою зону, даже если кликнуть на ползунок сразу выходит ошибка и за ней еще несколько повторяющихся до самого выхода из редактора. 
 Как решить эту проблему? Спасибо.

Эм.. не совсем понятно как это, запускать "при помощи загрузчика OBSE".
Может кто нибудь разъяснить на пальцах?

Эм.. не совсем понятно как это, запускать "при помощи загрузчика OBSE".

Может кто нибудь разъяснить на пальцах?

В свойствах ярлыка obse, в строчке Объект нужно дописать -editor. Как здесь "C:\The Elder Scrolls IV - Oblivion\obse_loader.exe" -editor.

В свойствах ярлыка obse, в строчке Объект нужно дописать -editor. Как здесь "C:\The Elder Scrolls IV - Oblivion\obse_loader.exe" -editor.

Спасибо :3

Что делать если прокручивание скрипта вызывает выбрасывание из редактора?

Видимо длинные старые скрипты эта модиФикация читать не может.

YourBunnyWrote
администратор
автор
13.08.2015 — 19:04

Всем привет! dll Fix тоже не помог. То есть весь редактор работает без проблем, но в редакторе скриптов при нормальном режиме где подсвечиваются элементы нельзя прокручивать текстовою зону, даже если кликнуть на ползунок сразу выходит ошибка и за ней еще несколько повторяющихся до самого выхода из редактора.

Как решить эту проблему? Спасибо.

Что делать если прокручивание скрипта вызывает выбрасывание из редактора?

Видимо длинные старые скрипты эта модиФикация читать не может.

Видимо, ты не разблокировал архив после скачивания. Как это сделать - написано здесь.

Видимо, ты не разблокировал архив после скачивания. Как это сделать - написано здесь.Странно

Блокировка с архива снята, но после переписывания результат не меняется.То есть скрипт открывается и даже прокручивается, но дойдя до определенного участка(возможно конец блока) происходит ошибка.  Что не так?

Если что то с установкой произошло, как тогда вычистить прогу под ноль? Потому что уже в третий раз все файлы удаляю и заново устанавливаю, но все тщетно. Скрипты там где больше одного блока этим страдают. Доходит до строки End и выходит множество ошибок закрывающих одна другую. А в обычном редакторе (когда в папке The Elder Scrolls IV - Oblivion\Data\OBSE\Plugins все файлы CSE отделяю в другую папку) все читается без проблем и так выяснилось что проблема в таких скриптах где больше одного блока. Чем это вызвано и как это исправить или как удалить программу что бы установить её снова, но как бы в первый раз?

YourBunnyWrote
администратор
автор
15.08.2015 — 20:10

Убедись, что ты выполнил все требования из раздела "Установка" из Construction Set Extender_readme.rtf. Если ты всё сделал правильно, то у меня нет вариантов. Могу разве что посоветовать спросить у автора модификации.

Убедись, что ты выполнил все требования из раздела "Установка" из Construction Set Extender_readme.rtf. Если ты всё сделал правильно, то у меня нет вариантов. Могу разве что посоветовать спросить у автора модификации..

Да все требования выполнены, да и редактор сам без проблем работает. Может как то обойти редактор скриптов что бы запускался оригинальный. Конечно подсветка элементов и подсказки это здорово, но досадно что он команды не дописывает, по крайней мере у меня. Так в принципе мне нравится подвижность камеры и упорядоченность измененных объектов, а без редактора скриптов выжить можно.

А как сделать чтобы автоматически убирались  постоянные всплывающие сообщения об ошибках в самом этом конструкторе, при просмотре и загрузке чего-либо? В скайримском редакторе это все можно было отключить двумя кликами в ини-файле, без всяких там обсе. Сдесь же все мне ничего не ясно.

И через обсе не могу запустить это конструктор. Ниже прочитал об этом, но мне все равно не понятно. У меня ярлык изменяется от переименования и становится нечитаемым, а следовательно и сам запуск. Как вы это делаете?

Ниже прочитал об этом, но мне все равно не понятно. Как вы это делаете?

Что же ты, Ганс, такой непонятливый? В архиве есть Launch CSE.bat - нажми на него и все запустится.

Всем у кого проблема с редактором скриптов - используйте версию 6.3

Кстати,блокирвку работы окна скриптов может блокировать ENB.Может быть,об этом уже здесь писали - но я не нашел. Перепробвал все версии -  пока не удалил enb.dll.

Здравствуйте люди, можете подсказать решение на мою проблему:

У меня стоит Золотой Пиратский Обливион OBSE последней версии, со всеми дополнениями и с паком модов. Когда я его скачал, меня предупредили, чтобы я не снимал в лаунчере галочки с модов и не менял их местами. Мне это делать и не хочется, и в общем по барабану как там они стоять будут.

Но кое что мне, неугомонному, захотелось подправить, да и карьера мододела очень уж прельщает. Так что скачал я ещё и Tes Construction, тоже для Золотой версии, открыл там несколько вкладок и начал модить, а именно- сделал бессмертными несколько персонажей (рыцарей Боевого Рога) и изменил инвентарь их графа. Меня сразу же насторожило то, что появилось немеряно вкладок с желтыми предупреждениями, очень-очень много таких. Я на всех нажал "не закрывать программу",чтобы TCS остался открытым, внес изменения (один раз выкинуло!) и включил Обливион. Так там заставка идет, а как план Имперского города, так темный экран, и даже применением Ctrc-Alt-Delet не всегда закрыть можно. Пробовал и через ярлык, и через лаунчер, одна и та же картина. Потом попробовал через TCS отменить внесенные изменения - так они сами не сохранились! (Очень, кстати, странно - кнопку save я точно же нажимал...)

Помогите, люди добрые!

уже вышла 7.1

"Распространяемый пакет Visual C++ для Visual Studio 2012" - теперь нужен "Microsoft Visual C++ 2015 Runtime", который, кстати, не у всех нормально встает. Без него обновленный CSE работать не будет, выдавая сообщение об ошибке. Читайте внимательнее требования к моду и своевременно обновляйте их.

YourBunnyWrote
администратор
автор
19.03.2017 — 11:41

Всё верно, забыл циферку поменять в описании. Спасибо.

Всем привет. Извините, если немного не в тему. Хотел узнать, может ли этот расширитель как-нибудь менять скрытые переменные, связанные с вампиризмом? К примеру: сделать так, чтобы при проигрывании анимации "укуса" на спящем нпц, ему наносился какой-либо урон? Или, если это не представляется возможным - вовсе убрать функцию "кормления спящими"?

Всем привет. Извините, если немного не в тему. Хотел узнать, может ли этот расширитель как-нибудь менять скрытые переменные, связанные с вампиризмом? К примеру: сделать так, чтобы при проигрывании анимации "укуса" на спящем нпц, ему наносился какой-либо урон? Или, если это не представляется возможным - вовсе убрать функцию "кормления спящими"?

Магические эффекты Вы никак не сможете изменить, если только не установите весьма багованный плаг - OBME. Хотя лично у меня он работал более-менее нормально. Но даже там, без 100 грамм не разберешься. Вообще, Вашу задумку можно реализовать с помощью скриптов, используя Хандлер OnVampireFeed. Можно попробовать сделать проверку на проигрывание Idle анимации питания, и в этот момент наносить урон. Способы есть, но их нужно пробовать и проверять.

Вышла 8-я, новая версия.

Всем привет. Извините, если немного не в тему. Хотел узнать, может ли этот расширитель как-нибудь менять скрытые переменные, связанные с вампиризмом? К примеру: сделать так, чтобы при проигрывании анимации "укуса" на спящем нпц, ему наносился какой-либо урон? Или, если это не представляется возможным - вовсе убрать функцию "кормления спящими"?

Better Vampire 
Sacrosant 
Еще 1 мод по мотивам Мира Тьмы

Better Vampire

Sacrosant

Каким боком скайримские моды относятся к редактору для четвертой части?

Каким боком скайримские моды относятся к редактору для четвертой части?

Я хз что я тут забыл, я как бы искал что то для 5 части и почему то меня кинуло сюда
Но впрочем с кем не бывало?

Когда я открываю скрипты, вылезает ошибка и выкидывает из конструктора. Кто знает, с чем это связано?

YourBunnyWrote
администратор
автор
01.08.2017 — 12:14

Нужно разблокировать архив с CSE в свойствах файла после скачивания.

Вот наконец то все пошло! Великолепно

У меня framework 3.5 sp1 и нормально Construction Set Extender 7.1 на Windows Xp работает! )))

Авторизуйтесь, чтобы оставить новый комментарий. Или зарегистрируйтесь.